VSee Enforcing TLS 1.2 on 1st Sept 2020

Please be informed that VSee will stop supporting TLS 1.0/1.1 and start enforcing TLS 1.2 next month.

1. Why is VSee deprecating TLS 1.0 and 1.1?

TLS 1.0 and 1.1 are out-of-date protocols that do not support modern cryptographic algorithms, and they contain security vulnerabilities that may be exploited by attackers. The Internet Engineering Task Force (IETF) is also planning to officially deprecate both protocols. In addition the vast majority of encrypted Internet traffic is now over TLS 1.2 which was introduced over a decade ago.

2. Until when will VSee API support TLS 1.0 and 1.1?

On staging, it ended on 15th Jul 2020.
On production, until 31st Aug 2020 only.

3. What will happen if I have any staging API that only supports TLS 1.2 for testing integrations?

If you are using VSee Messenger Web API, you can call api-tls1-2.vsee.com
If you are using VSee Clinic API, you can make an API call to api.vseepreview.com

4. What do I need to do about it?

Before Aug 31st, please upgrade your software to use TLS 1.2 when communicating with our API servers.

5. What will happen if I do not update my endpoints by Aug 31st?

Endpoints that are not able to negotiate a TLS 1.2 connection will be unable to access VSee API systems including the User API, URI API, Contact API, Message API, Chat Group API, Recording API, Stats API, Presence API, Clinic API.

If you have any questions or concerns, please contact our support team at help@vsee.com

 

Comments ( 0 )

    Leave A Comment

    Your email address will not be published. Required fields are marked *

    %d bloggers like this: